使用 cocoapods 时遇到的错误及错误的解决方案

Author Avatar
XibHe 8月 21, 2016
  • 在其它设备中阅读本文章

1.The dependency AFNetworking (= 2.6.3) is not used in any concrete target.

在cocoapods version 1.0 之后,默认生成的Podfile文件类似于

pod 'Alamofire', '~> 3.1.4'
pod 'SwiftyJSON', '~> 2.3.2'

这样的默认设置。为了不发生如标题那样的错误,需要手动用 target “TargetName” do end 把需要 pod 的库包括进来。

target "TargetName" do
    pod 'Alamofire', '~> 3.1.4'
    pod 'SwiftyJSON', '~> 2.3.2'
end

2.ios None of your spec sources contain a spec satisfying the dependency: IQKeyboardManager (~> 4.0.0).

报这个错误,可能是由于Cocoapods的配置库有损坏,Cocoapods建议删除本地副本重新clone。根据cocoapods官方博客的方案,在终端做出如下操作 (依照次序)

第一步:

sudo rm -fr ~/Library/Caches/CocoaPods && \

第二步:

$ sudo rm -fr ~/.cocoapods/repos/master
gem update --system && \
gem update && \
gem cleanup && \
pod setup

参考资料

Pod install displaying error in cocoapods version 1.0.0.beta.1

intergating New Firebase.. error cocoapods

pod repo update does not happen error in cocoapods

Repairing Our Broken Specs Repository

–EOF–

若无特别说明,本站文章均为原创,转载请保留链接,谢谢